How To Fix 'Your Device Isn't Compatible With This Version' On Play Store
How To Fix 'Your Device Isn't Compatible With This Version' On Play Store

Usually, we all love to try new apps on our smartphone, but sometimes while installing an app, we get a ‘Your Device isn’t Compatible with this version’ error. So, if you want to download a new game or app, and the app isn’t compatible with your device, then you no longer need to give up your wishes. Here we have shared 4 best methods to fix the error message.

If we look nearby, we will find an Android smartphone on every hand. It’s right now the most popular mobile operating system which is used by millions of users. The reason why Android behind such popularity relies on the platform itself. The mobile operating system provides users endless customization options.

Just take a brief look at Android’s Google Play Store, you will find apps for almost every different purpose. Usually, we all love to try new apps on our smartphone, but sometimes while installing an app, we get a ‘Your Device isn’t Compatible with this version’ error.

This is not an error, but it was a message that tells that your device is not supposed to run that app. Sometimes, users see the message even if the app or game is supported. So, here in this post, we are going to share a few best methods to get rid of the ‘Your device isn’t compatible with version’ error message.

So, if you want to download a new game or app, and the app isn’t compatible with your device, then you no longer need to give up your wishes. Just check out some of the best few methods given below to fix the ‘Your Device isn’t compatible with version’ error message.

#1 Clear Google Play Store Cache

Since we see the error message on the Google Play Store, we need to clear the cache and data of Google Play Store to fix the ‘Your Device isn’t compatible with version’ error message. To clear Google Play Store cache, follow some of the simple steps given below.

Step 1. First of all, open your Android’s App drawer and head to the Settings.

Clear Google Play Store Cache
Clear Google Play Store Cache

Step 2. In the Settings, find “Apps”

Clear Google Play Store Cache
Clear Google Play Store Cache

Step 3. Now on the list of installed apps, find Google Play Store.

Step 4. Click on the Google Play Store and clear the Cache and data.

Clear Google Play Store Cache
Clear Google Play Store Cache

That’s it, you are done! Now you need to restart to fix the ‘Your Device isn’t compatible with version’ error message.

#2 Uninstall Play Store Updates

If the above mention method failed to fix the ‘Your Device isn’t compatible with version’ from your computer, then you need to uninstall the Play Store updates. To uninstall Play Store updates, follow some of the simple steps listed below.

Step 1. First of all, open the App Drawer of your Android smartphone.

Step 2. In the next step, head to the Settings > Apps

Clear Google Play Store Cache
Uninstall Play Store Updates

Step 3. On the Apps, find ‘Google Play Store’

Step 4. Now, you need to tap on the ‘Uninstall Updates’ button.

Uninstall Play Store Updates
Uninstall Play Store Updates

That’s it, you are done! This will remove all updates from the Google Play Store. Restart your smartphone to fix the ‘Your Device isn’t compatible with version’ from your device.

#3 Uninstall Google Play Services Updates

Just like Google Play Store, you need to uninstall Google Play Services updates as well. To Uninstall Google Play Services, follow some of the simple steps listed below.

Step 1. First of all, open your Android’s app drawer.

Step 2. Now open settings and tap on ‘Apps’

Clear Google Play Store Cache
Uninstall Google Play Services Updates

Step 3. Now you will see the list of all installed apps. There you need to find the option ‘Google Play Services’

Step 4. Now you need to tap on ‘Uninstall Updates’

Uninstall Google Play Services Updates
Uninstall Google Play Services Updates

That’s it, you are done! This is how you can uninstall updates of Google Play Store to fix the ‘Your Device isn’t compatible with version’ error message.

#4 Using Market Helper App (Root Needed)

Well, if you have a rooted Android device, then you can use the Market Helper app. The app basically allows users to change the phone model. Here’s how you can use Market Helper to fix the ‘Your Device isn’t compatible with version’ error message.

Step 1. First of all, visit this link & download the Market Helper Apk on your Android smartphone.

Step 2. Once downloaded, head to the Settings > Security > Unknown Sources. Enable the Unknown Sources option from there and install the Market Helper App.

Using Market Helper App (Root Needed)
Using Market Helper App (Root Needed)

Step 3. Once installed, open the app from the App Drawer and you will see an interface like below. Here you can change the Phone model and operator.

Market Helper App
Market Helper App

That’s it, you are done! After changing the device information, head to the Google Play Store and download the app or game.

So, these are the four best methods to fix the Your Device isn’t compatible with the version from Google Play Store. If you know any other working method to fix the device isn’t compatible from Google Play Store, let us know in the comment box below.



AUTHOR

Amarnath Chakraborty
Amarnath Chakraborty is the content writer at Tech Viral. He writes/edits about how-to tips, tutorials especially on Social Networks, Android, iPhone, Computer, Internet etc.

LEAVE A REPLY

Please enter your comment!
Please enter your name here

This site uses Akismet to reduce spam. Learn how your comment data is processed.